当在 OS X 上编译部署 Ruby 时出现 “You have to install development tools first.” 错误时的解决方案

一般出现这个问题时在 Lion、Mt. Lion 往上的系统中,因为自从某个版本之后 Xcode 将 gcc 由 gcc-4.2 改为 llvm-gcc-4.2 所致。所以解决方法也很简单:

cd /usr/bin/
sudo ln -s llvm-gcc-4.2 gcc-4.2